Upgrading

Note: Presently only namespace values are upgraded in BEL files.

Install Ruby (Windows)

  1. Download RubyInstaller.
  2. Install RubyInstaller version.
  3. Open a command prompt (Windows Key + R then type cmd).

Continue with Install the bel gem.

Install Ruby (Mac OSX)

Option 1: Homebrew

  1. Install with homebrew by typing brew install ruby.
  2. Add ruby commands to your PATH.
  3. Confirm installation by typing ruby -v.

Option 2: rbenv

Continue with Install the bel gem.

Install Ruby (Linux)

Option 1: Install via package manager.

Option 2: rbenv

Continue with Install the bel gem.



Install the bel gem

  1. Open a terminal or command prompt.
  2. Use the gem command to install the bel gem.
  3. You should see the following:
    Fetching: bel-0.2.1.gem (100%)
    Successfully installed bel-0.2.1
    Parsing documentation for bel-0.2.1
    Installing ri documentation for bel-0.2.1
    1 gem installed
  1. Confirm you can access the bel_upgrade command.
  2. Continue with Upgrading BEL.



Upgrading BEL

  1. Type bel_upgrade --help for option details.
  2. Run command
  3. The upgraded BEL will be written to standard out. Simply redirect to a file after that.



Issues